Author Topic: Clean Burn 2800 oil pressure adjustment issue?  (Read 479 times)

DP

  • Gettin' the fire started!
  • *
  • Posts: 1
    • View Profile
    • Email
Clean Burn 2800 oil pressure adjustment issue?
« on: December 26, 2018, 06:28:20 pm »
Hello everyone. I am having an issue with my CB2800 waste oil heater. I recently had my unit serviced by PetroChoice (only two months ago, preheater block swapped, cabinet cleaned, barometric dampener swapped & stack replaced) & the unit has been running like a dream. Last Friday, our heater was off. When I hit the reset switch, I noticed that I had ZERO oil pressure after having perfectly consistent oil pressure the past three weeks (I believe it was at running smoothly at 4.5 PSI). Thinking I had an oil bleeding issue, I disconnected the oil line from the outside of the box to check my oil flow & I had surprisingly good oil flow at the burner. I reconnected the oil line & reset the burner to see if I had any oil pressure at all. Again, none. After I waited a half hour, I restarted the burner with the oil pressure adjustment screw slightly further down. I saw it barely move the needle, so I turned the adjustment screw a little bit more. Long story short, with the oil pressure adjustment screw all the way down to the maximum position, I couldn't get more than 2 PSI of constant oil pressure. I had zero fluctuations in oil pressure & strong oil pressure when bleeding the burner, so I took a look inside the burner box. Figuring I had a clog in the preheater block or something, I removed the box & disassembled the preheater block. It was JUST replaced when my burner unit was serviced by PetroChoice & was absolutely spotless inside. I removed the oil pressure gauge, and blew some low pressure air through the unit & nothing was clogged at all. I removed the oil pressure regulator (but did not disassemble) to make sure I didn't have a clog & re-assembled & re-installed the unit. Same exact issue. I called PetroChoice, but they can't come out for a few weeks.

Do these oil pressure regulators go bad? If they do, I can replace it, but I didn't want to throw parts at the unit. Again, I have zero fluctuations in oil pressure. I have good oil feed pressure at the burner box. The preheater block is definitely heating up. My oil gauge is functioning perfectly (I swapped an older one I saved just to be sure). I'm out of ideas, other than waiting for PetroChoice to come out, or ordering another oil pressure regulator to swap out myself in 1/4th of the time.

Does anyone have any advice, or know any common issues with these? Or should I stop touching the oil burner box & just wait two to three weeks to have PetroChoice look at it?

** In case anyone needs to know, I burn filtered automatic transmission fluid in this CB2800.

ShopSpecialties

  • Now that some heat!
  • ***
  • Posts: 140
    • View Profile
    • Email
Re: Clean Burn 2800 oil pressure adjustment issue?
« Reply #1 on: December 26, 2018, 10:30:21 pm »
Usually when regulators go bad the diaphragm tears and oil comes out the weep hole. You are saying they replaced the preheat block or did they clean it and install a service kit ? If the block was replaced with a new one see if there is a date stamped on it. 

ShopSpecialties

  • Now that some heat!
  • ***
  • Posts: 140
    • View Profile
    • Email
Re: Clean Burn 2800 oil pressure adjustment issue?
« Reply #2 on: December 29, 2018, 12:34:06 pm »
Did you get it figured out ?