Author Topic: Suntec pump not working?  (Read 20103 times)

Russ

  • Administrator
  • Master Oil Burner
  • *****
  • Posts: 500
    • View Profile
Suntec pump not working?
« on: January 30, 2009, 10:54:07 am »
Well, I think the pump on my burner might be bad.  I have air, spark, but no fuel.  I removed the line going up to the nozzle and nothing came  out of the pump.  I opened the bleeder and fuel came out of there.  Not a real high pressure stream, but it was shooting out.  I will remove the pump this weekend and see if there is anything obviously wrong.  Is there anything I should look for while I have it apart?

Thanks!

Kyle

  • Gettin' the fire started!
  • *
  • Posts: 45
  • next in line!
    • View Profile
Re: Suntec pump not working?
« Reply #1 on: January 31, 2009, 01:10:02 am »
Well I was woundering if someone had been playing with all those reducers....first try to bleed then adjust the pressure regulator on the side, if that doesen't work you can always pull the end plate, they have an internal screen on the suction side.

Russ

  • Administrator
  • Master Oil Burner
  • *****
  • Posts: 500
    • View Profile
Re: Suntec pump not working?
« Reply #2 on: January 31, 2009, 02:26:33 pm »
Yea, the reducers looked suspicious.  I suppose it broke down and they were working on trying to fix it.  Thanks for the suggestions.  I will give them a try and see what I can come up with.  Otherwise a new pump might be in order?

Kyle

  • Gettin' the fire started!
  • *
  • Posts: 45
  • next in line!
    • View Profile
Re: Suntec pump not working?
« Reply #3 on: January 31, 2009, 10:19:06 pm »
If all else fails, grainger carries them, but pay attention to the RPM it is rated for, and double check your motor, the last guy could have been wrong.

Russ

  • Administrator
  • Master Oil Burner
  • *****
  • Posts: 500
    • View Profile
Re: Suntec pump not working?
« Reply #4 on: February 01, 2009, 05:51:37 pm »
I took the pump apart today and things looked pretty dirty.  Lots of junk in there.  I removed the screen and took the pump apart further.  It looks like the gasket (or whatever you call it) has a small hole in it.  I am guessing that is maybe why the pump isnt working?  I see patriot supply has parts, but without part numbers it is pretty hard to tell what a person needs.  Is it even worth rebuilding these pumps or is it best to buy a new one?  Here are some pics of what I found:

Kyle

  • Gettin' the fire started!
  • *
  • Posts: 45
  • next in line!
    • View Profile
Re: Suntec pump not working?
« Reply #5 on: February 01, 2009, 08:25:34 pm »
looks like someone was trying the waste oil thing....just forgot to filter it

koolkris

  • Gettin' the fire started!
  • *
  • Posts: 26
    • Yahoo Instant Messenger - koolistdude
    • View Profile

Russ

  • Administrator
  • Master Oil Burner
  • *****
  • Posts: 500
    • View Profile
Re: Suntec pump not working?
« Reply #7 on: February 03, 2009, 10:08:02 pm »
Thanks for the link.  I checked it out, but unfortunately my pump requires the deeper filter.  I did finally end up finding the filter I needed with the help of these guys catalog:
http://www.strainerscreen.com/

They have lots of parts for the suntec pumps plus other heating and plumbing supplies.  They dont sell directly to the public, but I found that patriot supply carries quite a bit of their stuff.

The strainer and gasket were cheap at patriot, but shipping was a killer.  I cleaned up the screen and had a friend seal the pump with some kind of sealant.  The pump is working great again.  By the looks of these pumps, there isnt much that can wear out on them.  I have only pumped diesel through it so far, but I am sure it will handle waste oil just fine.

Blinky265

  • Guest
Re: Suntec pump not working?
« Reply #8 on: August 17, 2009, 02:27:34 pm »
If anybody in this forum needs parts, feel free to email me.  I work on commercial waste oil furnaces, but the parts to be the same.  I always have Setec screens and gaskets in stock, as well as solenoid valves, nozzles, ingnitors, primary controls, and I can probably match prices to what you might need.  If you need something, email me at ben@greatlakescleaningsystems.com . 


Russ

  • Administrator
  • Master Oil Burner
  • *****
  • Posts: 500
    • View Profile
Re: Suntec pump not working?
« Reply #9 on: August 18, 2009, 06:58:11 pm »
Excellent!  I will keep you in mind for parts I may need in the future.

erickh1

  • Guest
Re: Suntec pump not working?
« Reply #10 on: October 21, 2009, 02:07:36 pm »
Not all Waste oil furnace parts are the same, You maybe able to alter your burner to fit other parts, But this may void any warrenty on your unit, and possibly cause insurance problems if something goes wrong, If you alter a UL listed item, With non-approved replacement parts that makes the unit non UL listed and is considered not insuarable, and we all know how our insurance CO. are always looking for loop holes. Only replace parts with your brands factory authorized parts, and is best to get them from a factory authorized Dealer. Beware of your service dept. that says we can fix any brand with any part.

Russ

  • Administrator
  • Master Oil Burner
  • *****
  • Posts: 500
    • View Profile
Re: Suntec pump not working?
« Reply #11 on: October 26, 2009, 08:19:32 pm »
Good point on the UL listing.  And a good thing for anyone to keep in mind...SAFETY when working with these furnaces.